RE: [AD] AL_RAND(), final round |
[ Thread Index |
Date Index
| More lists.liballeg.org/allegro-developers Archives
]
> Writing
>
> #define AL_RAND rand
>
> is better, in case someone wants to take the address of AL_RAND :-)
>
> Ok with this change.
I disagree with this one, as it would break the portability that
it is meant to bring.
You could hackishly define it on other platforms as
#define AL_RAND() (rand()+rand()<<16)
or whatever else, but I'd rather all the macros to be the same,
rather than some with () and some without.
Besides, taking the address of AL_RAND might not be legal C code
if defined as above.
--
Vincent Penquerc'h