|Re: [chrony-dev] [PATCH] Privilege Separation - Version 2 - Add helper process|
[ Thread Index |
| More chrony.tuxfamily.org/chrony-dev Archives
On Thu, Nov 19, 2015 at 10:36:40PM +1300, Bryan Christianson wrote:
> I think it might be cleaner and more readable to keep send_with_fd() and receive_with_fd() and always call send_with_fd(), passing -1 if there is no socket to be transferred. i.e. no need for special case in send_to_helper().
I'm not sure if that would be more readable to me. I'd expect
functions named send_with_fd/receive_with_fd to always send/receive a
descriptor. But I'd not expect them to look at the data and do some
magic with it either. :)
To unsubscribe email chrony-dev-request@xxxxxxxxxxxxxxxxxxxx with "unsubscribe" in the subject.
For help email chrony-dev-request@xxxxxxxxxxxxxxxxxxxx with "help" in the subject.
Trouble? Email listmaster@xxxxxxxxxxxxxxxxxxxx.